ASP Executing VBScript Crashes Windows CE Device

I am experiencing strange behavior in my .ASP web page that is running on Windows CE (CUWIN5500 device).

The entire HTML/Script is this…

<html>
	<head>
		<title>Loop Test</title>
	</head>
	<body>
	<h3>WinCE Crashes After X-Amount of Looping</h3>
	
	<pre>
	<%
        for i=0 to 250
        response.Write(i)
        next
    %>
    </pre>
 </body>
</html>

For an unknown reason, the code above will (sometimes) crash the entire OS – specifically, the device freezes up to the point you cannot even move the mouse around. The only way to rectify the freeze is to reboot the device.

Additionally, and what makes the problem even more curious, if I append something else to the “i” index variable, the system will NOT crash/freeze up the device. For example, the update below DOES NOT crash the device…

<html>
	<head>
		<title>Loop Test</title>
	</head>
	<body>
	<h3>WinCE Crashes After X-Amount of Looping</h3>	
	<pre>
	<%
        for i=0 to 250
        response.Write(i & "<br />")
        next
    %>
    </pre>
 </body>
</html>

I do not know what is causing this problem to occur and I log it here in this post for future reference.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s